Trouble with getting nginx to run

Hi All,

I am having trouble with setting up the web. I tried to run hollaex web --setup and start. Here’s the problem that I am facing

I have tried to delete nginx file in templates/local/nginx and run ‘web --setup’ again but it still doesn’t work.

Thank you.

Hi there.

Can you try to restart the exchange server first with hollaex server --restart, and try to run the web afterward?

The restart for the exchange will fully regenerate the Nginx template, so it could be helpful for you too.

Thank you.

I think my problem is with the docker set up. Here is the error

Thank you in advance.

Looks like somehow your docker containers for the exchange are constantly crashing.

Can you try to get logs with hollaex logs command and attach it?

Here are the logs:

I actually need the full logs, especially the logs from the API container.

Can you run the hollaex logs --target API --lines 100 command to get the logs from API?

Also, please run hollaex logs --export <FILE_EXPORT_PATH> to export your log output, and attach it to the next reply.

That will be super helpful.


Here are the full logs



I could not run hollaex logs --export <FILE_EXPORT_PATH>. It shows this:

1 Like

The <FILE_EXPORT_PATH> should be your real system directory path where you want to save the exported file (For example: /home/dang). The command will work once you set the vault correctly.

Anyways, based on the logs you provided, looks like your database does not have some core data tables set. I think there was something that happened during the initial setup.

If you don’t have any critical data, I recommend you fully terminate the exchange and start over.

You can terminate the exchange with:

hollaex server --termiante

And you can start over with

You need the --force flag here, since you are setting up a terminated exchange.

hollaex server --setup --force

I also recommend you monitor the logs from the setup command while it’s running.

Please let me know how it goes.


1 Like

Hi there.
I have same problem after upgrade HollaEx CLI to v2.2.0 and HollaEx Kit v2.2.1. I have already done a few updates and there was no such problem as it is now. I have important data in database so I cannot start over with exchange installation.


Hi there.

There’s a new CLI version release (v2.2.1) with the issue fix at the Nginx upstream reload for the web container.

Please install the latest CLI by running bash at your HollaEx Kit dir, and restart the server and web.