The plugins disappeared since updating to version 2.1.3

I updated to version 2.1.3 and when I go to the plugin section under Operator Controls, I click on Add for any of the plugin, there is not data on the page for Version and Author. When I click on Add again and then add in the pop-up, I get a Bad Request as the plugin data is empty.

When I try:

I get: {“count”:0,“data”:[]}

Same with the following, not found:

I setup another instance on AWS and same result with a fresh install. The plugins are unavailable.

What do you see in Plugins explore? Do you see the plugins list?

This is what I see, all four of them:

But when I click on any of them, there is no data and the api says there is no plugin:

You can even try to do a fresh install as I did and got the same results. As a developer, it points me to the latest release having an issue.

1 Like

All fixed in version 2.1.4 and its all installed and working. I just got a fetch error when installing but it went through anyway.

1 Like

Glad it worked out at the end of the day!

Actually, the Bank plugin is not working 100% as there are new fields but they dont show on the client page.

You should reinstall it.

I did and made a field mandatory and the field is not visible on the client side and when you try to save, it says: Missing fields: acquirer_bank

You getting this after reinstalling the bank plugin on the latest kit?

Yes, latest release and when you configure the plugin, you can select the mandatory fields and when I select any of them apart from the old name and number, they dont show on the screen.