Server not working after connecting domain

So i just bought a domain on cloudflare so that i can connect it to my exchange. I ran the setup in my aws console and everything was working fine, the server was reaching the health page however after i ran the hollaex prod command, the cli couldnt issue an ssl certificate for me.

here is the error

Waiting for verification…
Challenge failed for domain glorycryptoexchange.com
http-01 challenge for glorycryptoexchange.com
Cleaning up challenges
nginx: [warn] conflicting server name “glorycryptoexchange.com” on 0.0.0.0:80, ignored
Some challenges have failed.

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: glorycryptoexchange.com
    Type: unauthorized
    Detail: 54.93.243.165: Invalid response from
    http://glorycryptoexchange.com/.well-known/acme-challenge/jwUJCnw4S17u1IY6Uur7eb-crMSbiQgPo2bwCRK6cEc:
    "<!doctype html><html lang=“en”><meta
    charset=“utf-8”><meta name=“viewport”
    content=“width=device-width,initial-scale=1,shr”

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address.
    Failed to issue SSL certificate by using Certbot. Please confirm your settings and try again.
    Failed to issue SSL certificate by using Certbot. Please confirm your settings and try again.
    [email protected]:~/hollaex-kit#

So then i decided to skip the SSL part and connect the domain without it however i realise that when i run hollaex status, the server doesnt reach the health page anymore.

Here is the error

Calling the exchange health page (http://api.glorycryptoexchange.com/v2/health) …

The health page is not responding. Please check the exchange is up.

If you just started the server, it could take a minute for the server to get fully ready.
Please try it again after few minutes.

404 Not found

404 There is nothing here!

If you are an exchange administrator, and facing this page after the initial setup, You probably missed to setup domain(s) for the exchange.

If you haven't bind domain(s) for the exchange yet, please run 'hollaex prod' command to do so.

Please visit docs.hollaex.com to see guides, forum.hollaex.com to get further help.

Regards, HollaEx Team.

[email protected]:~/hollaex-kit#

Does anyone know the fix to this?

Im one step away from launching but this is really getting in the way

3 Likes

Hi does the problem still persists?

2 Likes