I messed up configmap and deleted the docker web container... now what?

I had issues after the 2.2.1 update and tried all kinds of things to get the web to build but its still not working. I deleted all docker containers, tried editing the configmap, etc. to no available. Is it possible to recreate the initial web container? Right now I try building the web but it hangs and never complete it even after many hours.

How can I recreate the web container? Here’s what I tried:

Sending build context to Docker daemon 471MB
Step 1/15 : FROM node:12.18.3-buster as build
** —> 8de87569b730**
Step 2/15 : ENV NODE_OPTIONS=–max_old_space_size=3072
** —> Using cache**
** —> 0c87d5c58ebd**
Step 3/15 : WORKDIR /app
** —> Using cache**
** —> d1b04e716b52**
Step 4/15 : COPY package.json /app/package.json
** —> Using cache**
** —> e3a0665230dc**
Step 5/15 : RUN npm config set unsafe-perm true && npm install -g node-gyp && npm install --loglevel=error
** —> Using cache**
** —> 7fee45b0c679**
Step 6/15 : COPY . /app
** —> 2c20884cd867**
Step 7/15 : RUN npm run build
** —> Running in 5776ffe614ae**

[email protected] build /app
npm run build-css && react-scripts --max_old_space_size=3072 build

[email protected] build-css /app
node-sass-chokidar src/ -o src/

Rendering Complete, saving .css file…
Wrote CSS to /app/src/index.css
Wrote 1 CSS files to /app/src/
Creating an optimized production build…

After running that, I see with docker images that there is an image created but its not getting named. So I use docker tag and tag it. I then try to apply it and then I get errors such as:

Error: Cannot find module '/app/tools/general/random.js’
** at Function.Module._resolveFilename (internal/modules/cjs/loader.js:965:15)**
** at Function.Module._load (internal/modules/cjs/loader.js:841:27)**
** at Function.executeUserEntryPoint [as runMain] (internal/modules/run_main.js:71:12)**
** at internal/main/run_main_module.js:17:47 {**
** code: ‘MODULE_NOT_FOUND’,**
** requireStack: []**

So from what I understand, its not completely build…


Now if I do a hollaex status, I get that and the server keeps restarting:

9c4f7f755032 bitholla/nginx-with-certbot:1.15.8 “/bin/sh -c 'ip -4 r…” 4 minutes ago Up 3 minutes>80/tcp, :::80->80/tcp,>443/tcp, :::443->443/tcp local_krypterzexchange-nginx_1
00d4d9eaf467 bitholla/my-hollaex-web:latest “node app.js” 4 minutes ago Restarting (1) 35 seconds ago local_krypterzexchange-server-api_1
6ccbc2a792bb bitholla/my-hollaex-web:latest “node ws/index.js” 4 minutes ago Restarting (1) 35 seconds ago local_krypterzexchange-server-stream_1
4710c97ccd9e bitholla/my-hollaex-web:latest “node plugins.js 100…” 4 minutes ago Restarting (1) 37 seconds ago local_krypterzexchange-server-plugins_1
21ecf6e11d77 redis:6.0.9-alpine “docker-entrypoint.s…” 4 minutes ago Up 3 minutes>6379/tcp, :::6379->6379/tcp local_krypterzexchange-redis_1
c0c3cb720612 postgres:10.9-alpine “docker-entrypoint.s…” 4 minutes ago Up 3 minutes>5432/tcp, :::5432->5432/tcp local_krypterzexchange-db_1

Calling the exchange health page (localhost:80/v2/health) …

404 Not found

404 There is nothing here!

If you are an exchange administrator, and facing this page after the initial setup, You probably missed to setup domain(s) for the exchange.

If you haven't bind domain(s) for the exchange yet, please run 'hollaex prod' command to do so.

Please visit docs.hollaex.com to see guides, forum.hollaex.com to get further help.

Regards, HollaEx Team.


I even tried the method on GIT:

Web Application

HollaEx Kit uses Reactjs framework as a single page application and communicates with the back-end servers through REST API and Websocket channels.



You need to have nodejs and npm installed


  1. clone the repository
  2. cd web
  3. npm install

Run in your local machine

  1. HollaEx uses sass for styling. You need to generate css files before running the project. node run build-css builds all css files from sass styles in /src folder.
  2. npm start it will also listen to changes in sass files and autogenerates css files in there.


You can build the project by running npm run build and the projects builds the entire client in /build folder

And its not working!

1 Like

I am at a lost here since a brand new AWS Ubuntu Server 20 instance with a brand new exchange.
I tried doing a docker tag repositoryname:tag and then tried to apply it but its throwing all kinds of error as I suspect the image never got built properly.
So the issue seems to be that the image building process end without an error but never builds properly. I am using the following AWS image: ubuntu-focal-20.04-amd64-server-20210430
Docker Version:
Client: Docker Engine - Community
Version: 20.10.9
API version: 1.41
Go version: go1.16.8
Git commit: c2ea9bc
Built: Mon Oct 4 16:08:29 2021
OS/Arch: linux/amd64
Context: default
Experimental: true

Server: Docker Engine - Community
Version: 20.10.9
API version: 1.41 (minimum version 1.12)
Go version: go1.16.8
Git commit: 79ea9d3
Built: Mon Oct 4 16:06:34 2021
OS/Arch: linux/amd64
Experimental: false
Version: 1.4.11
GitCommit: 5b46e404f6b9f661a205e28d59c982d3634148f8
Version: 1.0.2
GitCommit: v1.0.2-0-g52b36a2
Version: 0.19.0
GitCommit: de40ad0

1 Like

If you are still having the web build stuck issue, please try to change the Node.js’ max_old_space_size value.

  1. Go to your HollaEx Kit folder’s /web/docker dir, and open the Dockerfile
  2. Edit the line ENV NODE_OPTIONS=--max_old_space_size=3072 to something higher.
    • Lets say if you have 8GB of RAM. update the value 3072 to 7168
  3. Save, and try to build the web again.

Let me know how it goes.

It doesnt work. I tried 10 time with new aws instances and always the same issue: nginx doesnt start after the server build and it carries the problem with building the web. Not sure how you got it to work on a fresh instance but there is clearly an issue as I am not the only one. Never had isse with previous CLI and was running for almost a year…

It was AWS’s console fault! I tried it with PuTTy and it worked just fine. Make sure not to use the AWS console when building your exchange!

Note to self: take care when using AWS console!

Ooohhh I see… Glad everything’s working out now! It’s a great insight for future reference.

I wonder what could be wrong with AWS? Anyway, this is a great thing to take note of.

I think it was timing out somehow but not showing any error. The minute I tried it using PuTTy, it all went just fine.

1 Like