Hollaex status error

I executed hollaex prod and set the domains correctly, but when I execute hollaex status I get this. Do I have to set api domain to another IP address? I tried hollaex restart, hollaex web --build, hollaex web --restart but still get network error when I try to login. What should I do?

Hi there.

Looks like there’s a forwarding issue of your local Nginx to your local HollaEx API server. Can you provide more information for us?

First of all, please run hollaex status and post the entire result of the command.

For next, please call the local API server without going through the Nginx server, by running curl localhost:10010/v1/health command and post the entire result. If you can get something, that means the HollaEx server itself is correctly set and running.

Lastly, please open your settings/configmap file at the HollaEx kit directory, check the HOLLAEX_CONFIGMAP_API_HOST and HOLLAEX_CONFIGMAP_DOMAIN values. Please reply to us with the exact values of them.

That’s it. That information would be super helpful for us to figure out what is going on in your system. I’ll wait for your reply. :slight_smile:

Thank you!

1 Like

I provide you the full output on these screens

Hi. Thank you for providing the information.

Looks like your configurations are all correct. I don’t see any misconfiguration there.

I think we should dig in a bit deeper.

The issue is definitely related to the Nginx. That is the digging point.

Can you please provide the nginx.conf file at your HollaEx Kit path/templates/local/nginx directory?

Also, providing HollaEx Kit path/templates/local/nginx/conf.d/upstream.conf file would be helpful too.

Those 2 files are directly related to the Nginx server functionality. So there would be an answer definitely.

Sorry for asking you to provide more information.

Thank you.

This is the output of both files, thank you for replying :slight_smile:

Hey. Thanks for posting the screenshots.

One thing I noticed is you enabled the SSL (HTTPS) connection for the server, but the HTTPS (TCP 443) port is closed on your system.

I could only detect that the HTTP 80 port is open on your IP.

Can you please make sure to open the 443 port for your server?

Also, on your HollaEx Kit Path/settings/configmap file, Both HOLLAEX_CONFIGMAP_API_HOST and
HOLLAEX_CONFIGMAP_DOMAIN keys should have https in front of its value.

So for example, HOLLAEX_CONFIGMAP_API_HOST should have https://api.crptrade.io as a value, not http://api.crptrade.io. It is the same for the HOLLAEX_CONFIGMAP_DOMAIN.

Once you updated those values on your configmap file, please run hollaex restart command to restart your exchange server.

Can you please check the connectivity after you open the 443 port first, and restart the server after you update the configmap file values?

I hope that this could fix your problem.

Thank you!

Hello, I tried opening port 443, changing configmap and run hollaex restart, also restarted the server, now the https works but still I get network error when I login…

Hi there. I apologize for the delay.

I noticed that your API server is now reachable with HTTPS.

Are you still getting the network error issue?

If so, please try to rebuild your web server by running hollaex web --restart.

It will help the HollaEx web to correct the API server URL internally.

Thank you.