Exchange is not available after the production

Hi. After running the kit on local host successfully I went for the production. First it got my domain names and everything then I created the A records and skipped the ssl parts. restarted the kit and rebuild it, but after if finished I couldn’t have access to both local host and the domain. How can I fix this.

Hi there.

Can you check your browser’s developer console to check which error you are getting?

Checking the network tab of the browser console would be helpful either.

If it’s an issue with the custom domain allocation, running hollaex prod command again to re-apply the domains and restart / rebuild the server with hollaex server --restart and hollaex web --build + hollaex web --apply <YOUR_TAG> would fix the issue.

Please let me know if you are still having an issue after going through the steps above once again.

Thank you.

Hey there yechan thank you for replying to my message. I ran the prod command again and did all the steps and it failed so Im now sharing both local host and my domain’s console and network as your requested. Thanks


I also have about 20 images which are same in my docker registry. Also all dns zones are pointing correctly to your end.

Also I got the console and network screenshots for local host api and domain api.

Hope these screenshots helps you!

In the meantime, I also tried terminating the exchange and running it again maybe something was misconfigured. it also didn’t work.

Hi there.

I think that it could be related to your firewall configuration.

There are no ports opened for your IP, as far as I can check it on my side.

Port 80 and 443 (HTTP and HTTPS) should be always opened to the public to make the exchange accessible.

Can you please confirm your firewall configuration?

Thank you.

Hi there. My hosts firewall seems ok. Also I turned off my Mac’s firewall and that also didnt help. So at the moment I’m trying to create another exchange with another machine if that’s gonna work. If you have any ideas to delete and reset all the kit and run it all again it would be fantastic. Because terminating doesn’t work for me.

Hey there.

To reset the existing HollaEx Kit, please run hollaex server --terminate to remove the server on your machine, and run hollaex server --setup --force to start over.

Those 2 commands will let you start the HollaEx Kit from a scratch.

And please let me know how it goes running the Kit on other machine :slight_smile:

Thank you.

Hi there again. thank you for helping me out. I finally was able to create the connection. the problem was indeed with the ISP network configuration and now has been solved.

1 Like