Can't revoke hmac token. Invalid API key error

Well, after many days trying to solve the situation, here I am asking for community help.

I was testing the DIY for some months; exchange wasn’t connected to dashboard and then I tried to connect it. In a stupid move, I revoked a recreated the network keys; you know, these ones

“Exchange Keys
Exchange network keys
Your exchange network keys are used to install your exchange. Your unique key should not be shared with anyone. Your exchange network key will also grant your exchange access the various crypto asset liquidity pools.”

So; I tried to use this solution:

The result is:

"~/hollaex-kit# hollaex toolbox --reset_hmac_token
Getting the HMAC Token from the HollaEx server.

Warning: Running this command will REVOKE your existing token without any additional confirmation!

Are you sure you reset (get) the HMAC token for your exchange? (y/N)
Issueing a security token for the HollaEx Network communication…

You already have an active Token! (API Key: null)

You could provide the existing token manually on the further menu.
If you dont have an existing token, you could also revoke the token at the

If you dont have an existing token with you, you could revoke and reissue it.

Revoking the token can’t be undo and would bring down the existing exchange running with the revoked token.
Please make sure that you are not running the exchange already.
Revoking the exisitng token (null)…
Failed to revoke the security token!

Please check the error logs and try it again.
You could also revoke the token through the"

Adding key and secret manually to “settings/secret” file shows this in the logs:

{“level”:“error”,“message”:“security/findTokenByApiKey invalid key xxxxb5f5e08807da3ac9d2d2axxxxxxxxxxxx”,“timestamp”:“2022-02-23T15:23:00.616Z”}

So now I’m absolutely clueless of what to do to fix this mess