404 not found - nginx

When having followed every step to install the exchange.
and SSL certificates.

Still getting the 404 not found - nginx

the servers are working fine. and also hollaex status points that exchange should be up and running.
but both domain and api are on 404.

1 Like

Hi there.

I assume that your domain configuration at HollaEx Kit could be wrong.
Can you reply me back with your values you put for both web client and api server?

You will be able to see DOMAIN and API_HOST configurations at configmap file, in your HollaEx Kit, /settings folder.

Thank you.

1 Like

I have tried now severall times to install the exchange on my server.
But I keep getting the 404 error.

The api status is true
{“name”:“Coincryptoexchanges”,“version”:“1.24.12”,“host”:“https://api.coincrypto.exchange”,“basePath”:"/v1",“status”:true}

But when I go to the normal domain
https://coincrypto.exchange it shows the Nginx 404 error

I have done the prod installation including SSL cert.

But when I go to https://coincrypto.exchange:8080 I get the following

When I go to http://coincrypto.exchange:8080 I get access without any problems.

Hi there. Sorry for the late reply.

Looks like your server itself is up and running, but having an issue with the SSL connection.

Can you share your Nginx configuration with us to investigate the issue further?

You can find it at your HollaEx Kit folder/templates/local/nginx/nginx.conf.

If your hollaex prod flow worked correctly, the Nginx configuration file should have codes to make the SSL connection work.

We will help you right away once you share your file in reply.

Thank you!